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WORKSHOP DESCRIPTION 

Forms are created to serve many purposes.  They are designed to be the primary interface for 
your database.  Most forms are used for data entry purposes and offer the best layout for 
entering, viewing, editing and deleting records.  Forms are based upon tables or queries and 
can contain graphical objects called controls.  Participants will become familiar with terms 
associated with forms and learn how to create and modify a form. 

PREREQUISITE 

Access 2003 Queries.  Specifically, you will need to know how to create objects, table relationship 
basics, and the fundamentals of database design.  

OBJECTIVES 

Participants attending this workshop will: 

• Identify terms associated with forms 

• Identify form types and how they are used 

• Create a form for data entry 

• Navigate through a form 

• Add records, delete records, sort records, and filter records 

• Add controls to a form 

• Change control properties 

• Change a form's tab order
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What is a Form? 
A form is a graphical interface usually used for viewing, inputting, and deleting data.  A form can also 
be a switchboard or splash screen. 

Why use Forms? 
• You have more control over the data users can view and manipulate. 
• You can control and enhance the appearance of your data, providing an interface that is easier to 

use and understand. 
• You can have multiple fields which link to several tables and queries. 
• You can use forms which have controls for performing actions, such as opening other forms or 

printing a report. 

Types of Forms 
• Splash Screen – A form used to provide information about your database. 
• Switchboard – A form used as an interface for opening other forms, tables, or queries and for 

performing actions, such as printing or creating a report. 
• Input Form – A form used for viewing, entering, modifying, and deleting data. 
• Pop-up Forms – A form used to relay information to a user. 
• Modal Form – A form which forces a user to respond to it before continuing with other actions. 
• Subform – A form that is embedded within a form. 
• Multiple-Page Forms – The typical data input form.  You can only view a single record at a time. 
• Continuous Form –  A form which connects the records to easily scroll through multiple records.  

Continuous forms are a good choice for forms with few fields. 

Terms to Know 
 
• Controls – Used to perform an action or contain information which is bound to fields in a 

corresponding table or query.  Controls can also display pictures with object frames and set label 
controls to display text. 

• Text Box – Area where you enter information to be transferred to the table or query. 
• Label – Displays text.  For example, it can identify information to be entered in a specific text box, 

name your form, or provide directions for users. 
• Bound Control – Source of data is a field in a table or query.  For example, the label in a form 

takes the name of the field defined in the table or query and the text box displays the table data and 
inherits the same setting as defined in the table or query. 

• Unbound Control – Information has no source of data from the underlying table or query.  For 
example, a label you add for informational purposes (e.g. “Fields with Red Labels are Required 
Fields”). 

• Calculated Control – Uses an expression as its source.  An expression can use data from a field in 
an underlying table or query of a form or report, or from another control on the form or report (e.g. 
[UnitPrice]*1.075 to calculate price with tax). 
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Toolbox 
When in Form Design View, the Toolbox will be present.  Specific options can be selected 
and set up from here.  The toolbox is comprised of the following options: 
 

 
 

Some of the more popular, informative and useful additions to a 
form can be controls such as: 
 
List Box – A control that provides a list of choices.  A list box 
consists of a list of values and an optional label.  
 
Combo Box – A combination of a list box and text box.  
Information can be entered into the text box or chosen from a pre-
existing list (set of values), which has already been created. 
 
Chart – A chart can be placed on the form to present a correlation 
of data from a table or query of which the form is based. 
 
Command Button – A control that runs a macro function or 
executes an event procedure such as saving a record or quitting 
Access. 
 
Control Wizard – If the Control Wizard is turned on, then when 
the graph, list box, combo box, option group, or command 
button tool is selected, the appropriate Control Wizard 
commences and creates the control according to your answers. 
 

 

To access more controls, use the More Controls button.   
 
To move the toolbox, drag it.  You can snap it under the current toolbars or over the status bar by 
dragging it to the respective location.  Additionally, you can alter its shape by placing your pointer on its 
edges.  When the pointer turns into a double-headed arrow, click the left mouse button and stretch the 
toolbox to its new shape. 
 

Creating a Form 

AutoForm Wizard 
AutoForm is a good choice for building a simple form that is based on a single table or query.  You can 
change the design of the form after it is created using Design View. 
 
1 Open the Northwind database. 
 
2 Select a pre-existing Table or Query.  Choose the Customers table by clicking it once. 
 
3 From the Toolbar, click the AutoForm button and a form will be created automatically. 
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Navigating in a form 
Navigating through a form is much like navigating through a table. 
 
1 You can tab through the fields to select the next field or click inside a field to select it. 
 
2 You can use the Record Selector to scroll through your records one at a time, reach the beginning 

or the end of a record set, or create a new record. 
 

Beginning Record Button    
 Previous Record Button 
 Current Record Number Total Number of Records 

     
Next Record Button  New Record 
  Ending Record Button 

 

 
3 Save the form as frmtblCustomers. 
 

Adding records to a table 
When adding records, look at the status bar when you are in each field for guidance on entering the 
data. 
 
1 Click the New Record button on the record selector bar. 
 
2 Add the following data. 
 
Customer ID BAYLO 
Company Name Baylor Enterprises 
Contact Name Kamryn Baylor 
Contact Title Owner 
Address 13265 Constance Ct. 
City Springfield 
Region IL 
Postal Code 09657-1177 
Country USA 
Phone (505) 555-1670 
Fax (505) 555-1671 
 
The data will be saved in the corresponding tables. 
 
3    Try to enter another record with the same Customer ID (BAYLO).  To exit the record press ESC. 
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Views 

 
Figure 1. 
The View 
Button 

There are three views associated with forms.  With a form open in any view, you can 
change the views by choosing View from the menu bar.  Also you can use the view 
button by either clicking the button and scrolling through the views (Datasheet View will 
not open this way) or clicking the arrow next to the button and choosing a view from the 
drop-down list. 
  
• Form View – Used to add, modify, and delete data.  This view offers a graphical interface.  Usually 

only one record is displayed. 
• Datasheet View – This view presents the data in a table format.  All the fields and records are 

displayed.  Data can be added, modified, and deleted in this view. 
• Design View – Allows complete control over the design of the form.  This view cannot be used for 

data entry. 
 

Form Wizard 
The Form Wizard offers step-by-step help with creating a form.  With the wizard, you can base your 
form on multiple tables or queries. 
 
1 Close the frmtblCustomers form. 
 
2 From the Insert menu choose Form. 
 

The New Form Dialog Box will appear. 
 
3 Choose the table or query from which you would like to 

base the form.  Choose the Invoices query. 
 
4 Select Form Wizard and click OK. 
 
5 Add the following fields: ShipName, ShipAddress, 

ShipCity, and ShipPostalCode.  Click Next. 
 
6 Choose the Columnar layout and click Next. 
 
Note: when using tabular layout for a form with few data fields, the data will be presented in a 
continuous form. 
 
7 Choose any pattern and click Next. 
 
8 Save the form as frmqryInvoices(Addresses). 
 
9 Choose the option Open the form to view or enter information and click Finish. 
 
10 Close the form. 
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Creating a form using Design View 
To make changes to a form, Form Design View must 
be active.  Changes such as moving and sizing text, 
altering fields, adding text to the form, adding new 
fields, setting the background and foreground colors, 
or inserting pictures can be accomplished in Design 
View. 
 
When Form Design View is active, field names appear 
inside the text boxes.  Data cannot be entered while 
this view is active. 
 
1 Click the arrow next to the New Object button.  In 

the drop-down list box, choose Form. 
 
2 Select Design View.  In the Choose the table or query where the objects data comes from: 

drop-down list box choose the Employee Sales By Country query and click OK. 
 
3 If necessary, click the Field List button.   
 
4 Add all of the fields to your form by dragging the fields from the field list and carefully placing them 

on the form. 
 
5 Size and arrange the text boxes and labels. 
 
6 Switch to Form View. 
 
7 Notice that the form has taken on the queries attributes and prompts you for a parameter value.  

Enter 01/01/90 for the Beginning Date and 01/01/99 for the Ending Date. 
 
8 Save the form as frmqryEmployee Sales By Country. 

Design Considerations 
When designing a form, it is important to pay attention to logical design and aesthetic appeal.  
Remember, a form is designed to be the primary interface with your database. 
 
• Emphasize important information by changing font styles. 
• Use shading and special effects. 
• Use lines and borders to separate data groups or highlight data items. 
• Arrange the data fields in logical order. 
• Arrange the tab order. 
• To show that a field cannot be changed, use a back fill of the same color as the form, have it 

appear flat, make the border transparent, and remove it from the tab order. 
 

The Formatting toolbar 
For changing fonts, altering font styles, and adding borders, you will want to use the Formatting 
toolbar.  To display the toolbar, switch to Design View, choose Toolbars from the View menu, and 
select Formatting (Form/Report). 
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Displaying the design grid and using snap to grid 
To better manage the placement of your controls, you will want to have the design grid displayed.  To 
display the grid choose Grid from the View menu.  To align your controls easier, you will want to have 
the Snap to Grid option toggled on from the Format menu. 

Formatting Tips 
 
Resize objects 
 
 
 

When an object is selected, sizing handles will appear.  Use them to resize the 
object.  The large handle in the upper left-hand corner of the selected control is a 
MOVE handle and will move the text box and label independently. 

List Fields 
 
 
 

Use the List Field Button to display the field names while in Design Form view.  Add 
fields to the form by selecting from the field list and dragging onto the form. 

Select multiple 
controls 

• Hold down the shift key and click on the controls 
• Use Select All option on the Edit menu 

Fit to Text A label can be sized to fit the text by choosing Format, Size, To Fit. 
Alignment Select multiple controls and use Format, Align to arrange the form. 
Size Controls To size controls relative to each other, use Format, Size (Tallest, Shortest, Widest, 

Narrowest) 
Layers Objects on a form can be layered by selecting Format, Bring to Front or Send to 

Back. 
 

Controls 

Check Boxes/Option Buttons/Toggle Buttons 
 
The best ways to display Yes/No values on a form is through the use of one of the following: 

 
Check Box – a check box appears checked when it contains a true/yes value and unchecked 
when false/no value. 
 
Option Button – an option button contains a dot when it contains a true/yes value and clear 
when false/no value. 

 
Toggle Button – a toggle button appears depressed when it contains a  true/yes 
value and appears raised when a false/no value. 
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Add a Toggle Button Control 
 
1 Close the form you just created. 
 
2 Create a new form in Design view based on the Products table. 
 
3 Open the field list. 
 
4 Click the Toggle Button tool on the toolbox. 
 
5 Drag the Discontinued field to the form. 
 
6 Add the caption &Discontinued to the toggle button. 
 
The same procedure can be used when creating an Option Button or a Checkbox. 
 

Create a Combo Box 
The Combo Box and List Box make it easier to input information and ensure that a value entered is 
correct. 
 
1 Close the form you just created without saving it. 
 
2 Open the frmqryInvoices(Addresses) form in Design View. 
 
3 Display the Field List. 
 
4 Make sure the wizard is toggled off and click the Combo Box Button. 
 
5 Click the CustomerID field from the Field List and drag the field onto the form. 
 
6 Resize the label and combo box. 
 
7 View the form in Form View. 
 
8 Save the changes. 
 

Dates & Times 
Dates and times can be automatically entered into the datasheet by creating a calculated text box. 
 
1 Open the frmqryInvoices(Addresses) form in Design View. 
 
2 Click the Text Box tool, and click the form to create a default sized text box or drag to create a 

sized box. 
 

3 Move the pointer inside the text box and click when it becomes an I-beam. 
 

4 Type either =Date() or =Time() and rename the label either Date: or Time:. 
 

5 View the form in Datasheet View to see the results. 
 
6 Save the changes. 
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Command Buttons 
Command buttons are used to execute pre-set commands such as saving a record or exiting a form 
with one click of the mouse button. 
 
To create a Command Button: 
 
1 Switch the frmqryInvoices(Addresses) form to Design View. 
 
2 Make sure the Control Wizard button is toggled on and click the Command Button control. 

 
3 Click on the form to place the control. 

 
4 The Command Button Wizard will appear. 

 
5 Select the type of command to execute.  Choose Form Operations under Categories and Close 

Form under Actions.  Click Next. 
 
6 Under Picture choose Exit and click next. 
 
Note: a bitmap graphic that is saved elsewhere on your hard drive can be used instead of the default 
Access graphics. 
 
7 Name the command cmdClosefrmInvoices.  Click Finish. 
 
8 Move/Resize the button accordingly. 
 
9 Save the form. 
 
10 View the form in form view. 
 
11 Click the button you just created. 
 

Adding a calculated control 
You can use a calculated control to calculate number fields or to combine fields, such as first name and 
last name fields. 
 
1 Open the Employees form in Design View. 
 
2 Add a text box to the form. 
 
3 Click in the text box and enter the expression =[FirstName]&” “&[LastName]. 
 
4 Click outside of the field and view the results in Form View. 
 
5 Close the form.  Do not save the changes. 
 
Note: in a calculated control, precede each expression with the = operator.  When you set the Name 
property of a calculated control, make sure you use a unique name.  Don’t use the name of one of the 
controls you used in the expression. 
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Control Properties  
Properties determine the characteristics of a specific form and text box.  Every control on a form has 
properties. 
 
To view all properties associated with a control: 
 

• Select the control and click the Property Sheet Button.   
Or . . . 

• Double-click the control. 
• Click the right mouse button on a control and select property. 
• Select the control and then select View, Properties from the menu. 
• The Header, Footer and Detail section of the form also has properties which can be displayed by 

double-clicking that section of the form. 
 

Property characteristics 
 
• Data Properties set the source and characteristics of data displayed in the control, such as default 

value, format, or number of decimal places. 
• Event Properties specify macro or event procedures such as saving a record or quitting access. 
• Format Properties define control characteristics such as height, width, or color. 
• Other Properties show the name of the control or status bar descriptions. 
• All Properties show all the properties associated with the control. 
 

Change the Default for a Control 
 
1 Open the frmtblCustomers form in design view. 
 
2 Display the property sheet for any control. 

 
3 In the Toolbox, click the tool for the type of control you 

wish to change.  Choose Text Box. 
 

4 The properties for the control appear in the property 
window. 
 

5 Change the default properties to the desired properties. 
 
6 Change the Special Effect to Shadowed. 
 
7 Now drag a text box on to the form. 

 
8 Once the  in the upper right-hand corner of the Properties dialog box is clicked, the changes will 

take effect. 
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Tab Order 
The tab order refers to the order in which a field is selected when 
the TAB key is pressed.  Auto Order is set to a left-to-right and 
top-to-bottom tab order.  Create your own tab order by selecting 
and dragging the control name to a new row location.  The tab 
order on a form can be changed by selecting View, Tab Order. 
 
 
 

Deleting Records 

To delete a record in form view click the Delete Record button.   
 
1 Open the frmqryInvoices(addresses) form and delete a record. 
 

Sorting Records 
You can quickly sort your records in form view. 
 
1 Select a field you would like to have the records sorted by. 
 

2 Click the Sort Ascending button.   
 
The sorts will be saved when you close the form. 
 

Filtering Records 
1 Open the frmtblCustomers form in Datasheet View. 
 

2 Click the Filter by Form button.   
 
3 Use the drop-down list boxes to choose the fields you would like to filter.  Choose Owner from the 

Title: field. 
 
Note: If you accidentally choose the wrong field, you will need to delete all of the field filters by pressing 

the Clear Grid button.   
 
4 Click the Apply Filter button to filter the data.   
 
5 Use the Record Selector to scroll through the records. 
 
6 Remove the filter by pressing the Remove Filter button.  It is the same button as the Apply Filter 

button. 
 
7 From this point, the Apply Filter button can be pressed again.  The filter will be saved, even after 

the form is closed. 
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To permanently save a filter as a query 
 
1 With the frmtblCustomers form open in Datasheet View. 
 

2 Click the Filter by Form button.   
 

3 With the Owner field still selected, click the Save as Query button.   
 
4 Name the query qrytblCustomers(Owners). 
 

Adding a Form Header or Form Footer 
You can add a header and/or footer to your forms.  These are often used to name the form or to give 
directions on filling out the form. 
 
1 Open the frmtblCustomers form in Design View. 
 
2 In the View menu, choose Form Header/Footer. 
 
3 Select the Label tool from the Toolbox and position the pointer in the form header.  Insert the text 

Customers Form. 
 
4 Change the text font to Arial and the size to 18. 
 
5 If necessary, increase the size of the header area and the text object to display the full text. 
 
6 Center the text from left to right on the form. 
 
7 Save the changes and switch to Form View. 
 
8 Return to Design View and select the footer area. 
 
9 From the Toolbox select the Text Box tool. 
 
10 Position the insertion point to the left edge of the form footer. 
 
11 Replace the “unbound” text with the code =date(). 
 
12 Delete the text label but do not delete the field containing the date. 
 
13 Save the changes and switch to Form View. 
 
Note: a page header and footer will only appear on a printed form. 
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Other Options 
Practice making other changes to the design of your form. 
 
• Change the text color. 
• Change the background color (use the Fill/Back Color button on the Toolbar). 
• Move City, Region, Postal Code and Country on a single line with the text labels below the fields 

(Hint: move the fields then use the SHIFT key to select multiple objects.  Select Format, Align from 
the menu bar). 

 

Creating a Switchboard Form 
A switchboard form allows you to control which forms are viewed and allows you to “hide” the database 
window. 
 
Create a switchboard which will open the Customers form and close Access.  Set the switchboard 
form to open when the database is open. 
 
1 Begin a new form in Design View. 
 
2 From the Toolbox click the Control Wizard button so that it is toggled on (depressed). 
 
3 Click the Command Button button.  Click in the Form Grid and size the command button. 
 
4 In the Categories: window, select Form Operations.  In the Actions: window, select Open Form, 

then click Next. 
 
5 In the What form would you like the command button to open? window, select Customers, 

then click Next. 
 
6 Select the Open the form and show all records. option.  Click Next. 
 
7 In the Text cell type &Open Customers Form.  Click Next. 

The & will set a hot key for the button. 
 
8 Name the command cmdOpenCustomersForm.  Click Finish. 
 
9 View the properties for the Open Customers Form button. 
 
10 Click the Other tab.  In the ControlTip Text field type Click Here to Open the Customers Form. 
 
11 Close the Properties window. 
 
12 Click the Command Button tool. 
 
13 Place the button on the form grid. 
 
14 Select Application in the Categories window and Quit Application in the Actions window, then 

click Next. 
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15 In the Text window, type &Exit the Database.  Then click Next. 
 
16 Name the command button cmdExitDatabase.  Click the Finish button. 
 
17 View the command button’s properties and click the Event tab. 
 
18 Select the On Click field and click the builder button  to view the code the wizard created. 
 
19 Exit the Visual Basic code builder and close the Properties. 
 
20 Save the form as frmSwitchboard. 
 
21 Close the form. 
 
22 With only the database window open, choose Startup… from the Tools menu. 
 
23 In the Display Form drop-down list box choose the frmSwitchboard form. 
 
24 Close the Northwind database and reopen it.  Click the any of the buttons on the Switchboard 

form. 
 
25 Reset the startup Display Form to Startup. 

Adding Fields from Tables or Queries 
If you have based a form on a query or table but decide that you need to add a field from a different 
table or query, you will need to use the Query Builder that is accessed through the form properties. 
 

 
Figure 2. The Form Properties Window 

1 Open the frmtblCustomers form in design view and 
choose Select Form from the Edit menu or click the top left 
corner of the form, then view the form properties. 

 
2 Click the Data tab and click in the Record Source field. 
 
3 Click the builder button.   
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The Query Builder will appear. 
 

 
Figure 3. The Query Builder 

4 Choose Show Table from the Query menu.  Click on the appropriate tab (either Tables, Queries, 
or Both) and add the object from which you want to get the fields.  Add the Orders table. 

 
5 Make sure your tables or queries have a relationship.  

If not, create the relationship. 
 
6 Add all of the fields that you want referenced on your 

form including the fields from which the form was 
originally based.  Add all the fields from the 
Customers table and all the fields except for the 
CustomerID field from the Orders table. 

 
7 Save the query as qrytblCustomerstblOrders and 

close the query. 
 
8 Now you can add text boxes based on the new fields.  

Your original text boxes do not have to be reset. 
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