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WORKSHOP DESCRIPTION

Overview

Reports are used to retrieve and present data as meaningful information in hard copy
format. Different types of reports include mailing labels, invoices, and monthly reports.
Reports can group records into many levels, compute totals and averages by checking
values from many records at once, and can be attractive and distinctive because you
have control over the size and appearance of everything on the printed page.

Prerequisites
Access 2007 Queries and Access 2007 Forms

Objectives
Participants attending this workshop will:

Identify terms associated with report creation

Become familiar with report sections and formatting tips
Create mailing labels

Create a summary report

Use bound and unbound controls in report modification
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GETTING STARTED WITH REPORTS

What is a Report?

Reports are used to retrieve and present data as meaningful information. Different types of
reports include mailing labels, invoices, monthly reports, yearly summaries, and department
phone lists.

e Reports display only the information you want, the way you want to see it.

e Reports group records into many levels and compute totals and averages by checking values
from many records at once.

e Reports can be attractive and distinctive because you have control over their design.

TERMS TO KNOW

Control

Everything added to a report — text, a picture, a graph, even a field from a table is a control.

Bound Control

A bound control is a control on a report, whose contents are bound to a particular field in the
undetlying table or query. For example, a text box that displays an employee's last name is
bound to the Last Name field in the Employees table. Binding is the act of setting up the
controls on the report.

Unbound Control

Information in a report you specify with the use of either the Wizard or Design View such as
title and/or column headings or labels.

Calculated Control

Any control in a report that involves a calculation of one or more fields, a date and/or time
expression, or a page number.

Sections of a Report
Information will appear on the report depending upon where certain controls are placed in the
design of the report.
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e [f data is retrieved from more than one table, the report must be based on a query.

Totals come from an expression which is stored in the report
design. Totals can be placed in either the Report Footer or the

e Prevent blank pages by making sure the report width plus the margins do not exceed the

paper size specified in Page Setup accessed when in Design View via the Page Setup tab

on the ribbon.

e Set page/print otientation in Design View by clicking the Page Setup button via the Page

Setup tab on the ribbon. Itis best to set this prior to adding controls to a report.

e To move and/or size any report controls, the sizing/moving handles must be active.

The title and column headings of the report are stored in the
report design and are placed in the Report Header and Page

Data is retrieved from the underlying table or query which the
report is based on and can be viewed in the Detail section of

CREATE A REPORT

Creating a report using AutoReport

This is the easiest way to create a report in Access. The wizard sets up margins, alignments, and
indentations where necessary. After the report is created, you may alter it to your specifications.
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Open the Northwind database.

From the Navigation Pane, open the Customers table.
From the Create tab on the ribbon, click the Report button.
Save the report as rpttblCustomers.

Close the report.

Close the Customers table.

o Ok, WN B

Creating a report using the Report Wizard

The report wizard lets you create a report step by step. You have more customization options
available to you when you use the wizard.

1 Select the Create tab on the ribbon and click the Report Wizard button. The New Report
Dialog Box will appear.

Report Wizard

2 Choose the table or query that contains
the information on which the report will
be based. Choose the Employees table. You can choose from more than ane table or query.

3 Add the following fields First Name,
Last Name, Job Title, Address, City,
State /Province, and ZIP /Postal Code.

4 Click Next.

Which fields do you want on your report?

Tables/Queries

Table: Customers El

Available Fields: Selected Fields:

5 Add Job Title for the grouping level.
Click Next. iy
6 Sort by Last Name and then by First e
Name, Chck Next. Home Phone -
7 Choose the Stepped layout and Portrait = [ =

orientation and click Next.

8 Choose a style and click Next.
9 Name your report rpttblIEmployees and click Finish.
10 Close the report.

Using Design View

Use Design View to create a report from scratch.

1 Select the Create tab on the ribbon and click the Report Design button.

2 Ensure the Field List is displayed. Click the Add Existing Fields button if it is not.

3 Add the following fields from the Suppliers table by dragging and dropping them into the
Detail section of the report: Company, First Name, Last Name, Job Title, Address, City,
State /Province, ZIP /Postal Code, and Country/Region.

4 View the report in Print Preview mode.

5 Save the report as rpttblSuppliers.

Note: It is often best to create a report using the most basic report of the Report Wizard and
then make modifications in the Design View. In this way, the margins and formats for the
headers, footers and detail section will be created automatically.
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ADDING CONTROLS TO A REPORT

Add a Label to the Report Header

Open the rpttblSuppliers report in Design View.
Select the Arrange tab.

Click the Report Header/Footer button.

Select the Design tab, click the Label button.
Click to place an insertion point in the page header.
Type the label Suppliers.

Resize, format, or move the label if necessary.

~No ok WODN B

Calculated Text Box

A calculated text box contains calculated fields or information not associated with the table or
query. Information such as the time, date or a page number can be placed in a report with the
proper commands.

Time/Date Text Box

With the rpttblSuppliers report open in Design View select the Design tab.

Click the Text Box button and place the text box in the far left side of the Report Footer.
Place the insertion point in the text box by clicking in it.

To place the current date and current time, enter the following: =Date() & " " & Time()
Size, format, or move the text box as needed.

ga b~ WN PR

1 Add a Text Box onto the far right of the Page Footer.
2 If necessary, delete the label of the text box.
3 Click inside the text box.
4 To place just the page number type: =Page
4(a) To place the code for Page # of # type: ='"Page " & Page & " of " & Pages
5 Delete the label.
6 Preview the report.

7 Save and close the report.

Sum Total Text Box

You can add fields to your report to calculate data. In this exercise, you will total the freight
field. You can further make the data meaningful by adding grouping and have the calculated
freight field give you the total freight for each customer. Groups and sums can be added via the
Report Wizard or can be added after a report is created.
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Create a new report in Design View based on the Orders table.

Ensure the Field List is displayed. Click the Add Existing Fields button on the Design tab
to display the Field List.

Add the Customer ID and Shipping Fee fields to the Detail section of the report.

Click on the Group & Sort button on the toolbar.

Click the Add a group button in the Group, Sort, and Total pane.

Add the Customer ID field in the Field/Expression field.

Click the More option in the Group, Sort, and Total pane.

Change the value from without a footer section to with a footer section.

Close the Group, Sort, and Total pane.

Click on the field to be calculated. Choose the Shipping Fee field, hold down the left mouse
button and drag the field onto the Customer ID Footer section of the report. Release the
mouse button.

Change the label to Shipping Fee Total.

Add lines above and below the Shipping Fee Total ficld in the Customer ID Footer.
Reduce the size of the Detail screen to eliminate empty space.

In the text box, type the following: =Sum([Shipping Fee])

Save the report as rpttblOrders(ShippingFee).

Adding a Picture

A picture or any OLE object can be placed onto a report.

A WDN PR

On the Design tab, click the Logo button.

Navigate to c:/Windows and choose a graphic file (c.g. Coffee Bean.bmp).
Click OK.

Resize the picture to fit in the design of the report.

Note: You can double-click on the image sizing border to automatically size the graphic. For
some graphics it is best to open the properties for the image control and choose the Format
tab and change Size Mode to Zoom or Stretch.

PRINT SETUP, PREVIEWING, AND PRINTING

As you are nearing the end of setting up the controls of the report, it is necessary to set up the
printing options of the report. Unless the defaults are changed, all reports will be oriented to
print portrait-style with 1-inch margins on all sides.

Page Setup Dialog Box

Select the Page Setup tab.
Choose either Portrait or Landscape for the orientation.
Change the margins as needed.
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SETUP PREVIEW BUTTONS

Layout View Button

Layout view shows the layout of the current report with data. You can make some changes to

the report in Layout View. If you wish to view the report exactly as it will be printed, choose
Print Preview instead.

Ca
i
- Haome Create External Data

Calibri |11 <

[-r-r-r-r-r-r

(view| (B 7 Ull===| ¢
7 Font
I %D] Report View F
- | « || E-Q

AFI Print Preview

[ = =]

Layout View
[ — =]
M Design View

ils

Print Preview Button

Shows how a report, form, datasheet, or module will appear when printed. Includes all records

in the report. Report View also gives you an accurate layout of the report with all of the data.
Report View also retains the standard ribbon.

CREATING MAILING LABELS USING THE LABELS WIZARD

The quickest way to create printed labels based on a table or a query is to use the Labels
Wizard.

Close any open reports.

Open the Customers table in Design View.
Change the data type for the Address field to Text.
Change the field size to 255 characters.

Save the table. Click Yes to the message.

Switch to Datasheet View.

In the create tab, click on the Labels button.

N AUt kA W -

The label wizard will now activate.
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8 Select the appropriate Avery number based on the dimensions of the label sheet you will be
using and click Next. Choose C2160. Click Next.

Note: to customize the label size: 1. Choose Customize. 2. In the next window, choose
New. 3. Give your label a custom name and change the size by clicking in the fields that are
set to 0.00. 4. Click the OK button. 5. If you have created custom label sizes, you can view
them by clicking the Show custom label sizes checkbox after starting the label wizard.

9 Choose the formatting options you would like. Change the font to Times New Roman, 8
point size, Normal font weight and click Next.
10 Choose the fields you would like to

- - Labeiwizad |
include on your labels by selecting the ST
ﬁeld frorn the Available ﬁeldS’ ]iSt 7 ‘what would you like on pour mailing label?

. Caonstruct your label on the right by chaaosing figlds from the left. Y'ou may alsa
and CliijI’lg the add ﬁeld button - type text that you would like to see an every label right onto the prototype.
Wheﬂ on the appfopﬂate line. Available fields: Prototype label: %
Choose the following fields: Address Al {CompanyMame}

. City {ContactMame}
Company, First Name, Last Region {addiass}
Name, Address, City Esﬁiiﬁ“e A N ) {F!Hegion} {PostalCode}
> > 5 {Cauntry

State /Province, ZIP /PostalCode,

and Country/Region.
Note: in the Prototype label: panel, be
sure to add the appropriate spaces and Carcl | <Back [ Wew> ] _ Fish

punctuation.
Figure 1. The Labels Wizard Fields window
11 Click Next.
12 Choose the fields you would like to sort your labels by and click Next. Choose Country and
Company and click Next.
13 Name your report rpttblCustomers(Labels) and click Finish. Close the report.

CREATING A SUMMARY REPORT

Create the Order Totals query

—

From the Create tab, click the Query Design button.

2 Add the Customers, Orders, and Order Details tables to the grid then close the Show
Table window.

3 Add Company from the Customers table; OrderID from the Orders table; and UnitPrice,
Quantity, and Discount from the Order Details table.

4 Save the query as qryOrderTotals.

Sort Ascending by Company.

6 Add a total price calculating fields to the right of the Discount field by clicking in the field

row and typing Total: [Unit Price]*[Quantity]. Run the query to test the results.

o
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Note: to view or write the contents of a calculated field it is often easier to Zoom the field by
pressing Shift+F2.

7 Add a second calculating field to the right of the Total field by typing WithDiscount:
[Total]-[Total]*[Discount]. Run the query.

8 Add a 10% discount to all orders with a total of $1,000 and greater.

9 Save and close the query.

Create the New Total Orders Summary report
1 From the Create tab, click the Report Wizard button.

2 Base the seport on the Summar Opions
qryOrderTotals query.

3 Add all of the fields to the What surnmary values would pou like calculated?
repott then click Next. Field Sum Avg Min Max Cancel |
4 In the How do you want to UnitFrice C O
. ; Show ———————
view your data? panel, choose Quantity - |_|>3 r _
. - — =" Detail and Summary
by Customers, then click Discount L rrr o5 o
Next. Total = _ =hmmary =
5 Donotadda grouping. Click WithDizcount LI W I [T Calculate percent of
Next total for sums
XT.

6 Sort ascending by Total.

7 Click the Summary Options
button and select Sum for the
Total and With Discount
fields.

8 Show Detail and Summary.

9 Click OK then Next.

10 Use the Stepped layout in Landscape, then click Next.

11 Set the style to Urban, then click Next.

12 Title the report rptOrderTotalsandSummary.

13 Click Finish to display the report.

MODIFYING THE REPORT

—

Open the rptOrderTotalsandSummary report in Design View.
2 Resize the Sum calculation fields and change the fields to currency format.

Note: View the properties of the fields, select the Format tab, and change the Format field.
3 Edit the report header control rptOrderTotalsandSummary to read Order Details and

Summary.
4 Ensure all labels are aligned properly over their data column.
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Edit the page header label for the WithDiscount field to read Adjusted Total.

In Layout view, move the Total field and label to be after the Discount field.

Change the Company Name label to bold, rralic and 10 point. Resize the field so that the
data in the field displays propetly.

In the CompanyName footer area list only the count information. Delete the following:
=”Summary for “ & ““CompanyName’ = “ & “ “ &. Add the = to the beginning of the
calculation.

Note: The field should now contain the following: =[CompanyName] & " ("' & Count(*)
& " " & IIf(Count(*)=1," detail record",'" detail records') & ")"

Preview the changes.

10 Close the report.
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